Alhamdulillah, setelah hampir 2 bulan ngoprek pixma iP1700 di Linux Mint, akhirnya tanggal 28 Januari 2008 Angga berhasil install pixma iP1700.
Salahnya dimana… Angga juga ga tahu seih… Pokoknya bantai saja.
Installnya ga jauh beda dengan pengaturan untuk Zencafe.

Bersemedi di rumah Pak Gugel, ketemu sama Mas Yogi & Becousz

Donlot driver 2200 via terminal

wget http://yodi.web.ugm.ac.id/unduh/printer/bjfilter-2.6_1-1_i386.deb
wget http://yodi.web.ugm.ac.id/unduh/printer/pstocanonbj_3.3-1_i386.deb
wget http://yodi.web.ugm.ac.id/unduh/printer/libcnbj-2.6_0-1_i386.deb

Udah itu install deh mulai dari libcnbj-2.6_0-1_i386.deb, bjfilter-2.6_1-1_i386.deb, pstocanonbj_3.3-1_i386.deb dengan mengklik 2 kali pada file yang bersangkutan. Nehh biasanya pas install pstocanonbj_3.3-1_i386.deb dimintai dependensi cupsysnya yaitu libcupsys2-gnutls10. Angga cari di Sypnatic Manager ngga ada, akhirnya minta wangsit lagi dengan Pak Gugel. Dapatlah disini, disini & disini. Oh ya untuk link yang terakhir, Angga sarankan sebaiknya jangan pakai versi sarge (oldstable). Karena bermasalah di pengaturan printer baik via administrasi dan web yang ga bise kebuka.

Nah setelah cupsys terlengkapi barulah bisa terinstall pstocanonbj_3.3-1_i386.deb. Lalu lalu coba restart cupsys:
$ sudo /etc/init.d/cupsys restart

Udah gitu atur printer di http://localhost:631. Bla bla dan seterusnya. Dannnnn begitu nyampe di halaman “make / manufacturer”, silakan pilih vendor canon, driver 2200. Tapi Angga ga pake cara ini karena ga berhasil. Angga pake cara pilih file 2200.ppd, ngebrowse ke /usr/share/cups/model.

Atur kertas dan sebagainya sesuai kebutuhan… Done

Lalu kenapa bisa sampe 2 bulan… Karena mentok di libcupsys2-gnutls10. Angga pake versi sarge oldstable. Buntu di situ melulu, ga coba versi yang lain. Jadinya bingung sendiri….
Tapi, sekarang udah kelar… Alhamdulillah